KAPOW

Welcome to the Kapow forum. Here you can get help, use your skills to help others and enjoy hanging out in the company of other Kapow Robot Developers.


REST service error 401

Share

tea

Posts : 11
Points : 127
Join date : 2018-09-05

REST service error 401

Post by tea on Wed Oct 31, 2018 6:40 pm

I am trying to run a robot as a REST web service. I am able to run it from Management Console with the "Test Service" funcionality, but I get the following error message when I try to run it from a robot in Design Studio with the "Call REST Web Service" action: 

Error from the Call REST Web Service action. Error calling REST web service. 401 loading from <mu url found from Management Console >?

My configurations are as follows: 
URL: The url that I found in Management Console in the REST column for the robot. 
Request: POST (I also tried with GET, same error.)
Specify raw body, and then entered XML from Management Console. 
Content type: application/xml
Accept: */*
Encoding: Unicode (UTF-Cool
Output: Load in browser

I tried with and without credentials for Management Console filled in. 

My REST web service robot has no input or output variables. The "Call REST Web Service action" is the only step of the robot from which I try to run the REST service. 

Any tips for troubleshooting?

    Current date/time is Tue Dec 18, 2018 11:07 pm